Reply
Visitor
Posts: 3
Registered: ‎12-31-2013

New Blu_rays not working, no network option.

I have the NS-2BRDVD, which by the way isn't well covered by your web-site but I digress. In the "setup" menu there is no "network" selection even though the manual (which suprisingly was listed) shows this function the unit does not. My problem is, some Blu-ray disks do play, mainly older disk's while newer disks keep going back to the main disk menu. Your literature claims that a firmware update could solve this ploblem, how ever I feel I have fallen victim to "planned obsolecence" as my system is now outdated and will force me to replace my currently working unit (on some disk's). Please tell me this is not the case and you have a fix for this. I would hate for Insignia to get a bad rap because of their preditory sales practices. I await with baited breath for a reply.  

Insignia Product Specialist
Posts: 1,351
Registered: ‎10-15-2013

Re: New Blu_rays not working, no network option.

Hello Dutch,

I can attempt to help, but I will need some information form you.  I need your name, phone number, email, and address.   DO NOT POST IT IN THIS THREAD!!!  Send me a private message with this information so I can attempt to look up your receipt.  If you have your receipt, the please provide me you customer service pin off of it and we can compensate you for your trouble.

Regards,
Jeremy
Insignia™ Support

Visitor
Posts: 3
Registered: ‎12-31-2013

Re: New Blu_rays not working, no network option.

Jeremy, thank you for the quick response however after further research I found that while my system did come with both a network and usb port, neither had been enabled through the system bios of the unit which is why they didn't show up in the menu. That does tend to make it rather difficult to update the units firmware. If you would like to post a link to the bios flash and the proceedure on burning it to disk and flashing it I would appreciate it. Thank you.

Visitor
Posts: 3
Registered: ‎12-31-2013

Re: New Blu_rays not working, no network option.

Jeremy, are you actually interested in helping or where you just after my personal info?

Is there a bios flash that will turn on my network and usb or not?

Is there a firmware update that will allow me to play the newer Blu-rays or not?

Should I just replace the unit?

If you can't help at least be honest and tell me!

 

Insignia Product Specialist
Posts: 1,351
Registered: ‎10-15-2013

Re: New Blu_rays not working, no network option.

[ Edited ]

Hello Dutch,

Sorry for the delay.  There is no current firmware.  The reason I'm trying to get your information is so I can find the receipt so I can further assist you towards a resolution.

Regards,
Jeremy
Insignia™ Support

Newbie
Posts: 1
Registered: ‎12-26-2015

Re: New Blu_rays not working, no network option.

HELP I have the same problem!!!

Insignia Product Specialist
Posts: 1,254
Registered: ‎08-27-2015

Re: New Blu_rays not working, no network option.

Hello Odzihozo,

Welcome to Community@ Insignia™!

 

Can you provide the model number for your product? It should start with NS-.

 

I would be happy to assist you with your product, what issue are you having?

Regards,
Ryan
Insignia™ Support