Reply
Newbie
Posts: 1
Registered: ‎06-13-2017

NS-P11W6100 Drivers missing after Windows 10 reinstall

Hello everyone I have problems with a Insignia 11.6 NS-P11W6100 2 in 1 tablet pc. When I first got it WIndows 10 worked and stuff but then I did a Windows 10 update and got hit with a Driver Overrstack error and it kept looping. I couldn't access recovery mode so I installed windows 10 from my usb. After I did it touch screen didn't work, orientation, basically everything that made it a tablet is gone and it is like a small litle laptop now. I tried using the drivers I got from the post about NSP11W6100 and the mediafire file for the NS-15 tablet. I have tried updating in device manager the grayed out HID controller's or the grayed out USB devices with either file and I just get device already has best update. I don't see any unkwown devices and am missing a lot of drivers. I only managed to get the Wifi working with the file from NS-P11 post but that was about it. Everything else is missing and I don't even have a battery icon and sound is out. Really frustrated trying to get this working. Anyone have any solutions or advice? Thanks