Reply
Newbie
Posts: 2
Registered: ‎02-12-2016

Re: NS-SB515

NS-SB515 and Ive had it for like 4 months

Insignia Product Specialist
Posts: 1,254
Registered: ‎08-27-2015

Re: NS-SB515

Hello bdavis21,

Thank you for responding!

Were you able to check all of the wiring from the source to the sound bar? Make sure you have good connections at all points. The subwoofer connects wirelessly so try to move it closer and see if that improves the quality. Since you at least get some sound to the sound bar it is not a pairing issue. 

 

If you try these steps and you feel the sound bar is still not functioning as it should you can take the sound bar, subwoofer and receipt into Best Buy to the Geek Squad counter for warranty evaluation. This set has a 1 year manufacturer warranty. 

Regards,
Ryan
Insignia™ Support

Newbie
Posts: 1
Registered: ‎03-16-2017

Re: NS-SB515

My subwoofer won't get any sound and I have done all the trouble shooting steps given in the manual. It's connected with a solid blue light and it's not blown. But I think I mixed up the power cords with something else. Could that be the reason the sub isn't working?
Newbie
Posts: 2
Registered: ‎02-17-2018

Re: NS-SB515

My subwoofer also used to be very powerful now there’s no bass at all. I’ve made sure it’s paired multiple times even followed the instructions in the manual and advice on here like unplugging and plugging back in. I have the NS-SB515. What else should i do? I haven’t had it a full year yet...bought in May of 2017, but I don’t have my receipt so it’s not like I could get the warranty on it. Advice?
Newbie
Posts: 2
Registered: ‎02-17-2018

Re: NS-SB515

Also the light on the subwoofer just slowly blinks. It makes zero noise at all also.
Newbie
Posts: 1
Registered: ‎03-24-2018

Re: NS-SB515

I can't get my Insignia bluetooth subwoofer and soundbar to pair up was working fine had no problem at all until I bought a nother one and now I can't get neither one to pair up🤔can someone please help me then tried everything.
Highlighted
Insignia Support
Posts: 304
Registered: ‎10-05-2017

Re: NS-SB515

Hello Shorty55,

 

Welcome to the Insignia Support Online Forum Community! I’m sorry to hear that upon getting another soundbar, and subwoofer neither are pairing correctly. I’d be happy to see how I can assist you further.

 

Can you please confirm that you’re only pairing one soundbar & subwoofer to one TV? Soundbars and their corresponding subwoofer aren’t able to be used in combination together. I’d be happy to offer a few specific troubleshooting steps for the models you do currently have.

 

Have you tried to power cycle your TV & Soundbar/Subwoofer? You can do that by unplugging everything a few minutes then plugging it all back together. I look forward to your reply to see how I can assist you further.

 

Respectfully,

 

Mariah

Insignia™ Support