Reply
Visitor
Posts: 9
Registered: ‎06-05-2014

Re: 42" lcd won't power up

Pretty serious Hijack of my thread here. Mods should be on that.....

 

It's official... My opinion is Insignia is pure garbage and you want to avoid these TV's like they have a plague. That's what I'll tell people when they ask.

 

I installed a used main board for $100.00 and the TV worked for less than an hour.This time it took out the power supply

I replaced the power supply but all I get is "Please Wait" and then nothing.

I purchased yet another main board but the same result persists.. "Please Wait" and then nothing at all.

I'm done investing time and money on this TV with less time on it than a single football game takes.

 

GARBAGE......Run away.....Run away !!! These TV's bite hard.

 

Thanks to those that offered a thought and good luck to all the other owners of this manufacturer of garbage..

Visitor
Posts: 9
Registered: ‎06-05-2014

Blinking Red led Codes ??

I'm a bit frustrated so bare with  me please.

 

That little red flashing led light means something....

Does anyone have a list of the error codes and what they mean ?

 

My TV is not working. (NS- L42q-10A) I think the main board has an issue. When i power on I get "Please Wait" and then nothing else

When I power back down, I get either three red led flashes or sometimes I get 6 red led flashes.

This is clearly an error code.

Does anyone here know what it means ?

If no one here has those codes... Insignia truly sucks and this site needs real information.

These problems are consistent over many Insignia models.

The usual suggestion of cycling the power button or get a service tech to look at it really doesn't do much for the majority of people I see posting in this thread.

The power supply,main board and other parts of these TV's are a snap to replace if you can figure out what the codes are telling you.

I replaced the power supply with no change.I replaced the main board and the TV worked for an hour (Total of 5 hours since new.These TV's are garbage) before dying again. I replaced with another main board and now get the flashing error codes.

I'm looking for good quality answers and help with my issue. Cycling the power button or suggesting a service call does nothing for me.

If no one has a list of those error codes, this is not the site to help me and if not here....I"m done with Insignia for ever.

If the codes can't be found here then I can't see investing any more time or money on this garbage. If you guys don' have them, I doubt anyone will.

Thanks for any suggestions and thanks for letting me vent a bit.

Insignia Product Specialist
Posts: 1,354
Registered: ‎07-21-2014

Re: Blinking Red led Codes ??

Hello Sp0iler,

Thank you for inquiring!

As I've mentioned before, Geek Squad handles all of our repairs. Because they are our "Repair Service", they are the ones that have any physical diagnosing information. The forums are primarily for troubleshooting, but not repair based questions due to possibility of risk of damage working with electronics, as well as risk of electrocution or shock. Once you get into actual repair questions that is not something we will support directly.

Because of that I referred you to speak with a Authorized Repair Tech, as they would be the most knowledgable regarding the questions you have.

Regards,
Jon
Insignia™ Support

Highlighted
Visitor
Posts: 9
Registered: ‎06-05-2014

Re: Blinking Red led Codes ??

Thanks Jon.

Smiley Happy